Communardo Software GmbH, Kleiststraße 10 a, D-01129 Dresden
0800 1 255 255

SharePoint 2013: Wenn Aufgaben auf der MySite nicht mehr synchronisieren

Als ich diese Woche mit den Aufgaben der SharePoint 2013 MySite gear­bei­tet habe, ist mir ein merk­wür­di­ges gel­bes Ausrufezeichen im unte­ren Bereich des Aufgabenbereichs auf­ge­fal­len. (Siehe Bild). Ebenfalls merk­wür­dig kam mir die Tatsache vor, dass die letzte Aktualisierung bereits drei Monate zurücklag.

tasks

Durch einen Klick auf das Dreieck erhielt ich wei­ter­hin die Aussage, dass irgend­et­was beim Synchronisieren der Aufgaben schief gelau­fen war, was wie­derum das weit zurück­lie­gende  Aktualisierungsdatum erklärte.

Ein, nicht so schö­ner, Nebeneffekt die­ses Problems ist, dass Aufgaben, wel­che einem Nutzer in Webseiten zuge­wie­sen wer­den, auf ein­mal nicht mehr in der MySite auf­tau­chen. Zuständig für die Aggregation der Aufgaben ist die neue Work Management Service Application, wel­che mit SharePoint 2013 ein­ge­führt wurde. Mehr Informationen zum Work Management Service fin­det ihr im Technet.

Ein ers­ter Blick in die Central Administration ergab keine grö­ße­ren Erkenntnisse. Im Bereich "Services on Server" befin­det sich der Work Management Service". Dessen Status befand sich auf Startet. Alles im grü­nen Bereich.

wms

Google ver­riet mir, dass feh­lende Berechtigungen auf der ent­spre­chen­den Service Application eben­falls die Problemursache dar­stel­len könn­ten. Auch hier alles im grü­nen Bereich.

Erst ein Blick in die Log Files brachte etwas Licht ins Dunkle. Dort tauch­ten sehr viele Security Exception mit dem Wortlaut "Login fai­led for user .…" auf. Unser Work Management Service Account hatte kei­nen Zugriff mehr auf die ent­spre­chen­den SharePoint Inhaltsdatenbanken. Die Ursache für das Problem lässt sich nur erah­nen. Die wahr­schein­lichste Theorie für unser Problem jedoch, war die Installation eines Cumulative Updates für SharePoint 2013. In Verdacht steht das Cumulative Update für August.

Nachdem der Worker Account wie­der Zugriff auf die Datenbanken besaß ver­suchte ich den Service neu zu star­ten. Leider ver­bes­serte das nicht das Fehlerbild.

Lösung

Hier die Lösung, die unse­ren Work Management Service wie­der zum Leben erweckte:

  1. Löschen der Work Management Service Application
  2. Eine neue Work Management Service Application anlegen
  3. Ich habe dabei den bereits exis­tie­ren­den Application Pool verwendet
  4. Service been­den und anschlie­ßend neu starten
  5. Zum Schluss einen Full Crawl auf allen Content Sources durchführen

Fünf Minuten nach Abschluss der Crawls waren die Aufgaben der MySite prall gefüllt.

Abschließend bleibt zu erwäh­nen, dass die Ursache für das Problem nicht ganz klar ist und dass höchst­wahr­schein­lich ver­schie­dene Lösungsansätze für das Problem exis­tie­ren. Einen habe ich euch hier präsentiert,

 

 

Related Posts

1 Kommentar

Bei mir war es aus­rei­chend, dem Account unter dem die Work Management Service Application läuft, Lesezugriff auf die Datenbank der Mysites zu geben.

Comments are closed.

Pin It on Pinterest