Communardo Software GmbH, Kleiststraße 10 a, D-01129 Dresden

Installation von Virtual Server unter Windows 7

Die schlechte Nachricht: in einer Standardinstallation von Windows 7 kann Virtual Server 2005 R2 nicht instal­liert wer­den. Die gute: das Problem lässt sich behe­ben. Die ent­schei­de­nen Hinweise dafür habe ich im Artikel Windows 7 and Virtual Server von Thomas Lee gefunden.

Den Download für Virtual Server 2005 R2 gibt's hier. Gleich vorab die Empfehlung: am bes­ten die Sprache ver­wen­den, in der auch das Betriebssystem ist. Mehr dazu wei­ter unten in die­sem Beitrag.

Nun lässt sich, unab­hän­gig von der gewähl­ten Sprache, stan­dard­mä­ßig die Installation nicht star­ten, es kommt eine Fehlermeldung, die sinn­ge­mäß besagt, dass Virtual Server 2005 R2 mit dem Betriebssystem nicht kom­pa­ti­bel ist.

Um die­ses Problem zu behe­ben, müs­sen die loka­len Gruppenrichtlinien ange­passt wer­den - dafür ver­wen­den wir den "Editor für lokale Gruppenrichtlinien" oder kurz: gpedit.msc in der Kommandozeile. Zuerst navi­gie­ren wir zu -> Computerkonfiguration -> Administrative Vorlagen -> Windows Komponenten -> Anwendungskompatibilität und akti­vie­ren dort alle Einträge mit „deaktivieren“im Einstellungsnamen. Danach sollte es unge­fähr so aussehen:

Als nächs­tes führt eine wei­tere Navigation uns zu -> Computerkonfiguration -> Administrative Vorlagen -> System -> Problembehandlung und Diagnose -> Anwendungskompatibilitätsdiagnose, wo wir alle Einträge deaktivieren:

Danach ist ein Neustart ange­sagt. Nach die­sem kön­nen wir (zumin­dest theo­re­tisch) Virtual Server R2 instal­lie­ren - die oben erwähnte Fehlermeldung beim Starten des Setups erscheint jeden­falls nicht mehr.

Allerdings emp­fiehlt es sich, vor Beginn der Installation die Komponenten für den IIS akti­viert zu haben. Wenn dies nicht der Fall ist (Standard nach der Installation von Windows 7), erkennt man das an fol­gen­der Warnung bei der Virtual Server Installation:

blank

Man hat nun die Möglichkeit, ent­we­der das Problem zu behe­ben oder die Verwaltungswebsite nicht mit zu instal­lie­ren (was man aber in der Regel nicht möchte) – sonst kann die Installation nicht fort­ge­setzt werden.

Dies erle­digt man unter "Windows Funktionen akti­vie­ren oder deak­ti­vie­ren" in der Systemsteuerung:

blank

Bei mir hat aller­dings auch die (aus Verzweiflung dann schon voll­stän­dige) Installation der IIS-Komponenten incl. eini­ger Neustarts keine Abhilfe geschaf­fen. Geholfen hat dann (bei der deut­schen Windows 7 Installation), auch eine deut­sche Virtual Server Installation zu ver­wen­den. Schön, dass wenigs­tens in einer Beziehung alles so ist wie immer…

Danach lief dann alles wie am Schnürchen und ich kann meine vir­tu­el­len Maschinen nun wie­der benut­zen. In einer Firma mit einer grö­ße­ren Anzahl von Windows 7 Clients könnte der nächste Schritt sein, die oben beschrie­be­nen Manipulationen an den Gruppenrichtlinien auto­ma­ti­siert zu verteilen.

23. Dezember 2009

Bin gerade dar­auf hin­ge­wie­sen wor­den, dass das von mir geschil­derte Verfahren nur ab Windows 7 Professional und auf­wärts funk­tio­niert. In der Home Premium bei­spiels­weise hat man kei­nen Zugriff auf die Gruppenrichtlinien.

neuer Blogpost zu #VirtualServer unter #Windows7 http://tinyurl.com/yhclon8
This com­ment was ori­gi­nally pos­ted on Twitter

Das oben geschil­derte Problem, dass trotz Installation der IIS Dienste, ein Fehler erscheint, hat ver­mut­lich mit den Administratorrechten zu tun. Bei mir war es zumin­dest so, dass bei Rechtsklick auf die Setupdatei "Als Administrator aus­füh­ren" die Fehlermeldung nicht mehr erschien (vor­her hatte ich das glei­che Problem).

Hallo Dorrit,

wenn die Installation posi­tiv durch­ge­führt wurde, wel­che der per GPO deak­ti­vier­ten bzw. akti­vier­ten Einstellungen kön­nen dann wie­der rück­gä­nig gemacht wer­den - die Einstellungen an der loka­len GPO sind Schutzmechnissmen für W7. Sind die per GPO gemach­ten Änderungen nur für die Installation nötig oder auch für den Betrieb von Windows Virtual Server 2005? Vielleicht hast Du das bereits getestet.

Viel Grüße

blank Dorrit Riemenschneider

Hallo Andreas - nein, habe es nicht aus­pro­biert. War kurz vor Weihnachten froh, dass ich es ein­fach mal zum Spielen gebracht hatte… Inzwischen benutze ich Virtual Server nicht mehr unter Windows 7, son­dern statt­des­sen Virtual Box (um auch 64bit-Systeme wir SharePoint 2010 auf mei­ner Kiste vir­tua­li­sie­ren zu können…)

Viele Grüße
Dorrit

Hallo Dorrit,

danke für die schnelle Antwort - ich habe etwas län­ger gebraucht. Es geht aber - man kann alle Einstellungen an der loka­len Richtlinie wie­der zurück­neh­men, wenn man eine kleine "Manipulation" durchführt.

Nach dem man alle Deine Schritte durch­ge­führt hat und der Virtual Server läuft; in der loka­len Richtlinie alle Änderungen wie­der rück­gän­gig machen - Neustart. Der Dienst Virtual Server wird nun nicht gestar­tet. (Kontrolle unter Dienste, Dienst ist da, nicht gestar­tet und läßt sich auch nicht star­ten) Jetzt die Manipulation: Umbenennung der vssrvc.exe in z.B. vssrvc-modi.exe, im Regelfall unter C:ProgrammeMicrosoft Virtual Server zu fin­den und
Ändern aller Einträge der Registrierung, in denen vssrvc.exe vor­kommt in vssrvc-modi.exe (Registry suchen…) Neustart und es funktioniert.

Ich benö­tige Virtual Server für Microsoft Learning Szenarien und damit funk­tio­niert das - lokale Richtlinie sau­ber und Virtual Server läuft.

Nachdem ich das auch alles pro­biert hatte… fand ich den Weg die rich­tige Lösung nutzen:
Microsoft® Hyper-V™ Server 2008 R2 

http://www.microsoft.com/hyper-v-server/en/us/default.aspx

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=48359dd2-1c3d-4506-ae0a-232d0314ccf6&displaylang=de

blank Dorrit Riemenschneider

Hallo Frank, HyperV ist natür­lich auch eine Möglichkeit - eben eine andere. Wie bereits erwähnt, nut­zen wir seit gerau­mer Zeit Virtual Box und sind damit recht zufrieden.

Hallo,

ich hab alles befolgt komme aber lei­der nicht über die IIS Warnung hinüber.
Habe die IIS Dienste Aktiviert und das Setup als Admin gestar­tet lei­der ohne verbesserung.

Grüße

blank Dorrit Riemenschneider

Hallo Matze, die loka­len Gruppenrichtlinien hast Du bestimmt bereits ange­passt, oder? Und der Virtual Server ist auch in der glei­chen Sprache wie das Betriebssystem? Wenn das alles der Fall ist, dann fällt mir auf Anhieb höchs­tens noch ein Windows Update als mög­li­cher Verursacher ein… Wir ver­wen­den mitt­ler­weile nicht mehr Virtual Server, son­dern Virtual Box, so dass ich nicht weiß, ob der aktu­elle Windows Patch Stand Probleme ver­ur­sa­chen kann…
Viele Grüße, Dorrit

Comments are closed.

Pin It on Pinterest