Communardo Software GmbH, Kleiststraße 10 a, D-01129 Dresden
0800 1 255 255

SharePoint Content Type Hub: "Es wurde kein gültiger Proxy gefunden..."

Beim Veröffentlichen eins Inhaltstyps im Content Type Hub kommt der Fehler "Es wurde kein gültiger Proxy gefunden, der diesen Vorgang ausführen kann".
Dieser Beitrag zeigt Ursachen und Lösungsmöglichkeiten für das Problem auf.

Neulich bin ich beim Versuch, im Content Type Hub einen Inhaltstyp zu ver­öf­fent­li­chen, auf fol­gen­des Problem gesto­ßen:

Die Veröffentlichung schlug mit der Fehlermeldung "Es wurde kein gül­ti­ger Proxy gefun­den, der die­sen Vorgang aus­füh­ren kann" fehl. Dabei war es gleich­gül­tig, ob der Inhaltstyp initial oder erneut ver­öf­fent­licht wer­den sollte.

Die Lösung war letzt­lich sim­pel, hat mir aber doch erst­mal eini­ges Kopfzerbrechen berei­tet. Deshalb will ich diese der Community nicht vor­ent­hal­ten 🙂

Im SharePoint ULS Log fand sich unter der zuge­hö­ri­gen CorrelationId mehr­mals die glei­che Meldung wie oben bereits auf­ge­führt und zusätz­lich noch "No proxy asso­cia­ted with the site http://example.sharepoint.com/cth reco­gni­zes the site as a hub site"

Lösung

Das Problem kann ver­schie­dene Ursachen haben.

Generell sollte fol­gen­des geprüft wer­den:

In der Content Type Hub Site Collection

Das Site Collection Feature für "Inhaltstyp-Veröffentlichungshub" muss akti­viert sein:
Content Type Hub Feature

In der SharePoint Zentraladministration

  1. der Managed Metadata Service muss gestar­tet sein
  2. unter > Web Applications > Web Application, in der die Site Collection für den Content Type Hub liegt  > Service Connections muss der Managed Metadata Service akti­viert sein:
    Managed Metadata Service Connection
  3. Folgende Optionen müs­sen akti­viert sein in den Eigenschaften im Service Application Proxy für Managed Metadata (unter > Service Applications > Managed Metadata Service Proxy > Eigenschaften):
    Managed Metadata Service Application Proxy
  4. die unter > Service Applications > Managed Metadata Service > Eigenschaften ein­ge­stellte URL der Content Type Hub-Site Collection muss kor­rekt sein:
    URL der Content Type Hub-Site Collection

Wenn das alles nicht geholfen hat…

… dann könnte die Ursache die glei­che sein wie bei mir:

Die URL, die in der CA in den Eigenschaften des Managed Metadata Service für den Content Type Hub ein­ge­tra­gen war, stimmt nicht exakt mit der Aufruf-Url für den Content Type Hub über­ein.

Dieses Phänomen kann zum Beispiel auf­tre­ten, wenn ver­schie­dene Urls für inter­nen und exter­nen Zugriff gebraucht wer­den. Oder auch ganz ein­fach, indem mal die offi­zi­elle Url (mit DNS Name) und mal jene unter Verwendung des Servernamens benutzt wird.

Beispiel:

  • Url aus Eigenschaften des Managed Metadata Service: http://example.sharepoint.com/cth
  • "Fehlerhafte" Aufruf-Urls für den Content Type Hub
    • http://servername/cth
    • http://example-extern.sharepoint.com/cth

Die Lösung ist denk­bar ein­fach:

  • es ist völ­lig uner­heb­lich, wel­che der URL-Varianten in den Eigenschaften des Managed Metadata Service ver­wen­det wird
  • es muss aber beim Aufruf des Content Type Hubs die glei­che Variante ver­wen­det wer­den, ansons­ten kommt der beschrie­bene Fehler

Übrigens ist das Ändern der Url aus den Eigenschaften des Managed Metadata Service ist bei Bedarf per Powershell mög­lich:

Set-SPMetadataServiceApplication "Managed Metadata Service" -HubUri http://example.sharepoint.com/cth

Related Posts

Pin It on Pinterest