Communardo Software GmbH, Kleiststraße 10 a, D-01129 Dresden
+49 (0) 351/8 33 82-0

Warnung vor Greenhopper 5.10.4 – Update

Atlassian hat vorgestern das JIRA Plugin Greenhopper in der Version 5.10.4 veröffentlicht. Diese Pluginversion führt aber auf aktuellen JIRA Systemen zu schwerwiegenden Fehlern.

Zuerst lässt sich das Plugin zwar erfolgreich installieren, allerdings nicht aktivieren. Im Log wird ein Fehler angezeigt. Sollte das JIRA neugestartet werden, so scheitert der der Neustart an diesem Plugin. Erst, wenn das Plugin gegen eine ältere Version getauscht wurde, lässt sich JIRA wieder nutzen.

Das Problem konnten wir auf einem Testsystem mit JIRA 5.0.3 reproduzieren. Es gibt weiterhin Berichte, dass das gleiche Verhalten unter JIRA 5.0.6 auftritt.

Sollte das Update bereits durchgeführt sein, muss das Plugin über den Universal Plugin Manager deinstalliert werden und die Version 5.10.3 (oder eine andere ältere Version, die 5.10.3 ist jedoch problemlos nutzbar) manuell heruntergeladen und installiert werden. Die ursprüngliche Konfiguration und auch die Lizenzdetails bleiben dabei erhalten. Nebenstehende Grafik zeigt die Option des manuellen Pluginuploads.

Sollte Greenhopper bereits aktualisiert sein und JIRA lässt sich nicht mehr starten, so ist es möglich, die bestehende greenhopper.jar in dem Ordner installed-plugins durch eine funktionierende Datei einer älteren Version zu ersetzen. Diese muss dazu manuell über den Marketplace heruntergalden werden.

 

[Update 29.06.2012] Atlassian hat ein weiteres Update für Greenhopper herausgebracht, Version 5.10.4.1 um das Problem zu beheben. Wir konnten das kurz nachprüfen und das Plugin kann offensichtlich ohne Einschränkungen genutzt werden.

Kommentar hinterlassen


Pin It on Pinterest